发新帖

关于TensorFlow导入包的问题

[复制链接]
56 1

快来加入 TensorFlowers 大家庭!

您需要 登录 才可以下载或查看,没有帐号?加入社区

x
我在colab上面运行tff有关的代码如下:
import  collections

import numpy as np
import tensorflow as tf
import tensorflow_federated as tff

tf.compat.v1.enable_v2_behavior()
#TODO(b/148678573,b/148685415):must use the ReferenceExecutor because
#it supports unbounded references and tff.sequence_* intrinsics
tff.framework.set_default_executor(tff.framework.ReferenceExecutor())



但是得到如下报错:
[color=var(--ansi-red)]ImportError: This version of TensorFlow Addons requires TensorFlow version >= 2.1.0; Detected an installation of version 1.15.0. Please upgrade TensorFlow to proceed.我尝试将TensorFlow升级到最新版本,但是仍然报错。我还试过删除TensorFlow重新安装2.1.0版本也报错。我试过降级,但是提示tff支持的是2.1.0版本以上的,现在问题还没有得到解决。


我知道答案 回答被采纳将会获得10 金币 + 5 金币 已有1人回答
本楼点评(0) 收起

精彩评论1

biu  TF荚荚  发表于 2020-3-19 16:51:54 | 显示全部楼层
新建一个笔记本把原来的代码贴过去一点毛病没有
本楼点评(0) 收起
您需要登录后才可以回帖 登录 | 加入社区

本版积分规则

主题

帖子

3

积分
快速回复 返回顶部 返回列表